易语言—笔下文学电子书在线阅读

4个月前 (01-02) kgdin 个人随笔 0评论 已收录 362℃

易语言---笔下文学电子书在线阅读

最近在学习写这个电子书在线看的,去除了广告,也学到了很多的编程知识,在这里编写的

时候也遇到了很多问题,但经过不懈努力,暂时都解决了。还有很多细节方面的问题,没有

改变,不知道该怎么写才能写出来。但是不会放弃的。

编写手记

.版本 2

页数 = 到数值 (文本_取出中间文本 (编辑框_网址.内容, “0/”, “.htm”))
updown = 到文本 (页数 + 1)
编辑框_网址.内容 = 到文本 (编辑框_a.内容 + updown + “.htm”)

在这个获取下一页的时候遇到了问题,不知道怎么才能整出来。后来在论坛问了下大神,

给提了一个意见,清空内容,重新写入,才知道这样写。。

.版本 2
.支持库 iext
.支持库 spec

超级列表框1.全部删除 ()
临时源码 = 访问网页 (编辑框_网址.内容)
调试输出 (临时源码)
正则.创建 (#常量5, 临时源码)
.计次循环首 (正则.取匹配数量 (), z)
索引 = 超级列表框1.插入表项 (, , , , , )
调试输出 (正则.取子匹配文本 (z, 1))
超级列表框1.置标题 (索引, 1, 正则.取子匹配文本 (z, 3))
超级列表框1.置标题 (索引, 2, 正则.取子匹配文本 (z, 2))
超级列表框1.置标题 (索引, 3, 正则.取子匹配文本 (z, 4))
超级列表框1.置标题 (索引, 4, 正则.取子匹配文本 (z, 5))
超级列表框1.置标题 (索引, 5, 正则.取子匹配文本 (z, 6))
超级列表框1.置标题 (索引, 6, 正则.取子匹配文本 (z, 7))
超级列表框1.置标题 (索引, 7, 正则.取子匹配文本 (z, 8))
超级列表框1.置标题 (索引, 8, 正则.取子匹配文本 (z, 9))
处理事件 ()
.计次循环尾 ()

超级列表框获取网页内容的时候,不知道这个正则怎么写,有是在论坛里面问大神。在这里

真的很感谢这些大神们,正则在匹配的时候工具上面匹配的是正确的,但是跟易语言里面的

正则是不一样的,所以我们要学会这个  调试输出()  希望这篇文章能帮助到你们。

目前遇到的问题就是,当编辑框的内容为某一个特定的值得时候,运行另外一个命令。。

软件截图 




 


软件功能

1.当软件页面下一页到第3页的时候,列表框就不显示了,需要按在编辑框点击一下按回车键,才显示

2.阅读界面,还没添加字体,没有排序,看起来杂乱无章

3.阅读某一个小说,点击进去后,文章没有排序,杂乱无章

4.软件无搜索功能。

5.软件目前已实现在阅读界面的时候,可以直接使用下一页功能。

博主

这货来去如风,什么鬼都没留下!!!

相关推荐

博主大大,还木有人评论哦。 0条评论